"Investment" Tab - inaccurate calculation and numbers

Incident Report for Relai

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 11:11 CET

Identified

We are aware, that some users still have trouble with the correct display of the Investment Tab. We are already working on a fix.
Posted Aug 04, 2025 - 12:13 CEST

Monitoring

We have identified this issue and a fix has been deployed. You might have to restart your phone to see the exact numbers again. If not, please reach out to our support.
Posted Jul 30, 2025 - 13:38 CEST

Investigating

We are aware that some users having issues with the correct display of their "Investment" Page. We are currently working on it. This is a visual bug only, your bitcoin are always safe!
Posted Jul 30, 2025 - 08:31 CEST