Lightning Swap-Out Transactions Failing Due to Incorrect Limit Calculation

Incident Report for Relai

Resolved

This issue has now been resolved.

The bug affecting Lightning swap-out transactions due to incorrect limit calculations is no longer relevant, as Lightning channel closures are now fully functional again with the latest app update.

As part of a broader product strategy, we’ve also made the difficult decision to sunset the Lightning Wallet functionality in the Relai app. With that in mind, we encourage all users who still have Lightning bitcoin in their wallet to take action before June 2025.

You can do this by choosing one of the following options:
1. Transfer your Lightning funds to another Lightning-compatible wallet you control.
2. Use the “Close Lightning Channels” button on the app’s landing page to close all remaining Lightning channels and withdraw your funds on-chain.

For more context on this decision, please visit our Help Center and search for the article titled “Lightning Wallet Sunset.”
If you have any questions, you can contact us anytime via the in-app support chat or by email at [email protected].

We appreciate your understanding.
Posted May 20, 2025 - 13:00 CEST

Update

Our team has identified the root cause of the Lightning channel closure/swap out issue. We expect a full fix in the upcoming app update 3.0.3, targeted for release within the next 2–3 weeks (counting from May 7).

We will post an update here once the fix is live.

If you have any questions, please reach out via the in-app support chat.
Posted May 07, 2025 - 13:40 CEST

Identified

Some users are receiving an error message when trying to swap Lightning BTC for on-chain BTC, stating that they should try again later.

The issue is caused by a bug in the swap-limit calculation, which incorrectly determines the limit and prevents successful swap-out transactions.

Workarounds:

✅ Try swapping a different amount – If selecting the maximum amount results in an error, try a slightly lower amount instead.
✅ Send to another Lightning wallet – If you need your Lightning BTC immediately, you can send your funds to another Lightning wallet you control and withdraw from there.

We apologize for the inconvenience and appreciate your patience.
Posted Mar 17, 2025 - 15:31 CET